Important Message

You are browsing the archived Lancers Reactor forums. You cannot register or login.
The content may be outdated and links may not be functional.

To get the latest in Freelancer news, mods, modding and downloads, go to

*FIX* MP Internet Connection Issues - FIREWALLS

The place to ask for technical help with running the demo or the full game...

Post Thu Jan 19, 2006 3:55 pm

I am having the same probs "Connecting to Global Server..." stays on forever. I have played FL for ages, but after a small absence I tried to return today. But does not let me.

The only change between the last time I played, and now is that I upgraded my connection from DSL to cable. Nothing more nothing less...and I had issues with DirectX 9. But that should not cause issues since FL uses DX8, which worked fine!

All other gaems work though, Lineage II, Halo, Fear...they all connect without any problems.


I found out what my prob is. Its DirectX..its messed up! Only way I can reinstall is by reformating...not willing to do atm

I am guesing that others have the same prob. Go to start, that run and type: DXDIAG.EXE

Allow it to finnish the check up, than go to Networking. I get the following errors:

The registry information for the service provider 'DirectPlay8 TCP/IP Service Provider' is missing or damaged.
The registry information for the service provider 'DirectPlay8 IPX Service Provider' is missing or damaged.
The registry information for the service provider 'DirectPlay8 Modem Service Provider' is missing or damaged.
The registry information for the service provider 'DirectPlay8 Serial Service Provider' is missing or damaged.
You should reinstall DirectX to get the latest version.

I am guesing this is what is causing all the problems. It seems that it occured after instal of DirectX 9c. Anyone else shares the same thing?

Edited by - Leonhart on 1/19/2006 7:32:07 PM

Post Sun Jan 22, 2006 5:39 am

Hey guys, I've just read all of this and tried all of it...but me and a friend of mine still have the same problem.

When on Multiplayer, says "Connecting to Global Server" for a while, then crashes. I just got a new computer (Compaq Presario) and on my 5 year old computer with WinME I had no problem.

I've checked DirectX, everything is fine, its not my sound either.

This is really starting to bug me...

Post Sun Jan 22, 2006 6:40 am

What firewall are you using?

Edited by - Finalday on 1/22/2006 6:59:45 AM

Post Sun Jan 22, 2006 9:28 am

I have Windows Xp and McAfee 2005, but I had McAfee on my old PC and there was no problem.

Edited by - Starwalker. on 1/22/2006 9:29:43 AM

Post Mon Jan 23, 2006 10:57 am

Someone please help, this problem has obvoisuly affected a lot of other people and in most cases has not been solved...

Post Sun Jan 29, 2006 9:19 pm

I am posting here because I am having the same issue as Noxincendium, yakuru, and One Time Poster. I also know that at least one other person at the LAN party I was playing at had the same issue (we resorted to playing on other people's PCs, and for now my copy of FL is basically singleplayer-only!).

Yes, we were just playing on a LAN. My PC can see LAN/Internet servers fine; it can enter the game if I'm docked just fine. This isn't the same firewall issue since the server lists populate OK. Besides, I run WinXP SP1, so there's no way Windows Firewall is getting in the way. I do have an NVIDIA firewall (network card is integrated into the nForce chipset), but I swear I have tried all possible exceptions (allowing Freelancer.exe full access, outbound traffic [all protocols to port 2303, etc.). In fact, while I was on the LAN I had the firewall completely disabled, so the issue really makes no sense.

My DirectX install seems to be fine, but I am going to double-check it next. I'm in a position to reinstall Windows easily, so if nothing else works I'll back up the files I want to keep and start fresh.

I'll post here if I find something that works for me. The guys at my LAN party seemed to think they ran across the solution to this problem at some point, but of course they couldn't remember what it was :-P Perhaps they'll come up with it, or perhaps they don't know what they're talking about! I mean, if the problem were resolved, I bet the fix would be published all over this site. So...

Or maybe someone here _can_ help after all. While it's possible this is a new problem as suggested, it would be really strange to me if it's cropping up everywhere 'all of the sudden'. I would think someone else has experienced this before. But even if someone has, I guess the odds are low that they'll see these posts =(

When I reload Windows though (because I'm betting I'll have to at this point), I will try Freelancer relatively soon after getting back into the OS, before I apply a bunch of recent patches, etc. in case it's a resent piece of software that started this compatibility problem.

AMD Athlon FX-55
2x GeForce 6800 GTS
2x WD Raptor 72GB drives
No other known issues at this time.

Text of related posts below, to have it all in one spot.
"Ok I have a connection issues but not due to firewall issues. I'm connected through a router and for some reason when I log onto a server I instantly get a network connection warning (flashing red network symbol comes up) and then I get disconnected from the server. This happens on any server I try to play on, and it only happens on this game and no others....I've even tried DMZ host and nothing seems to let me stay connected"

"i have the same pb right now, i reinstall the game to play with friends but when i connect on a server, same thing, red computers appear and after 20 sec i'm disconnected.....and when my friends comme too on my server i just create (i opened ports), same, disconnected, but them they can play on others servers, no pbs.
I just have a modem with router incorporate so i dont understand what to do....can somebody can help me ?"

One Time Poster:
"I am having the same problem as the above poster and the other person.

I have no firewalls on my computer, but I am behind a router. I have opened the specified UDP ports on my router's firewall and it still doesn't work.

To clarify: I can see a list of servers. Whenever I go into a server, I can chat on a planet forever. However, as soon as I try to fly in space, the game gives me a connection problem after about 5-10 seconds. I am running an Athlon 64 with SLI Video card so it can't be that the computer isn't powerful enough. The offline game runs fine. It is only multiplayer that gives me the problem.

This is an extremely frustrating problem. There doesn't seem to be many help on this topic anywhere. Microsoft's tech support is a joke and there doesn't seem to be many active forums for this game anymore.

If anyone can help, please do. This seems to be a new problem that some people are getting."

Post Mon Jan 30, 2006 3:50 am

I decided to put this post here as it's the closest topic to my problem. I've read through the thread and have noticed others with the same problem. (I have also tried the suggested fixes that apply as well). The other day I was playing FL on a UK server and for an unknown reason my ISP dropped carrier. (I obviously then was logged off my game of FL). However, shortly after this occured (and after my internet access resumed), I attempted to load the multiplayer section of FL and connect to a server. The game tells me that it is connected to the Global Server, and that internet games are available, but no list appears? (I can connect to other game servers without a problem). I have attempted a reinstall/reboot, DxDiag, refreshing the list, I have made no changes in the status of my firewall (have re-checked and double checked them, even tried without a firewall at all and added the proper ports for good measure), I have disabled any other devices that FL might recognize in lieu of my modem. I have tried all that I know, and all I've seen that has been suggested. Does anyone have idea why this problem would occur, or of any bugs/glitches that may cause this? Any help is greatly appreciated ahead of time.

Post Wed Feb 01, 2006 12:27 pm

Zeppelin you seem to have a similar problem to me, except your FL worked before the ISP crashed. I cannot find any explanation for this, as my multiplayer works on every other game.

Post Wed Feb 01, 2006 1:39 pm

I seem to have a different problem.

I'm trying to run a server on my computer, and access it from the same computer. I've done this before, on a different computer; the server should be showing up as a LAN game, but now Freelancer isn't seeing it for some reason. Any ideas?

Another question: would the v1.1 patch prevent me from creating a server that's using a mod, or does it only prevent client-side mods?

Edited by - Crimson Wing on 2/1/2006 1:41:29 PM

Post Fri Feb 17, 2006 12:45 pm

I want to just advise anyone who has an nForce3 or 4 chipset who is using the nVidia ActiveArmor Firewall that many people have reported issues with the software and strongly recommend not installing or using it.

So if you're having trouble and you use that firewall software, try getting rid of it and see if that cures it (you can always enable the XP SP2 firewall or buy a router if you're not sure about security).

Post Thu Mar 09, 2006 9:12 pm

I can't connect to my server from another PC on the LAN. Others online can see it and connect but I get as far as the password screen and then it times out trying to make the connection. Any ideas as to what I should be looking for?

UDP ports 2302-2304 are open and no software firewalls are running.

Post Tue Mar 28, 2006 3:48 am

Why isn't something being done about these problems? I have found many people who's internet says "Connecting to global server" then crashes or nothing comes up (I'm the first one). Obviously the problem isn't the firewall, as full access has already been given. Do Microsoft not have a solution for this? I mean it worked fine on Windows ME, but not XP?

This is a desperate plea :p

Post Thu Apr 27, 2006 12:18 am

The 1.1 patch will only stop players attempting to use things not available in the game - be it modded or unmodded. Ie - launching after buying a ship that wasn't for sale originally on that base (as in the user hacks the files to change what's for sale in comparison to the servers files).

Nearly every issue is with a firewall when it comes to freezing whilst trying to get MP.
As for connecting to the same computer you're running the game as a server from - try looking for internet games - mine appears there...

Post Thu Apr 27, 2006 12:20 am

If you are experiencing crashes instead of connecting, then please try disabling 3D sound in your options menu BEFORE attempting to connect to the internet.

Post Sat Jun 03, 2006 10:10 am

I have a problem with hosting servers that started not too long ago. I was able to host servers with no problem then everything went downhill when I updated Windows. I tried everything included in this thread but to no avail. Is there any specific approach to fixing this problem?

Return to Freelancer Technical Issues