Important Message

You are browsing the archived Lancers Reactor forums. You cannot register or login.
The content may be outdated and links may not be functional.

To get the latest in Freelancer news, mods, modding and downloads, go to

cant create characters with server admin 2 mod

Here you can find news, get help and comment about all the Mods for Freelancer created by Pathfinder Studios, such as the ?Evolutions Mod?

Post Thu May 20, 2004 10:43 am

cant create characters with server admin 2 mod

Hello Chips,
I hope I have posted in the correct forum and you can help me with a problem. I was using your excellent Server Admin 2 mod in conjunction with Ion-cross IFSO on my server. Every thing was working fine except: problem 1:the AI shield regeneration ,which i could not get to work. problem 2: "This is the most important !" After trying several different starting ship and starting locations changes (testing) I started getting a "character name already in use" error. Neither I nor anyone else could create a new character. After a trying several things I decided to wipe the server clean and start over, as it was only a test setup anyway, and I assumed the server held all account information. Now for the hard part. I hope you will be able to help me and I have seen a similar problem posted on another site by the "Mercenary Navy" also using your mod, where they were unable to create characters. I am unsure if they have since corrected the problem, but if so the solution has not been posted. As for me after wiping and reloading the server i expected everything to return to the previous working setup, but no such luck. Now (even with fresh downloads / installs of all programs including xp) every time I try to load up your excellent server mod no one can create characters. If i inactivate the mod we can make characters. I don't think the problem is with your mod directly but i really would like to use it again. I have also reloaded my fl game and I still get the "character name already in use" error and it is still using the same account id number and will not regenerate a new account number. I have been banging my head and searching for an answer for a week now and no luck. I pray you have a suggestion for me on how to fix this error / problem.
Thanks in advance! Any help will be greatly appreciated.

" Living clean in a dirty world " Jesse Duplantis

Post Thu May 20, 2004 10:44 pm

Problem 1, it won't work if the mod your using already has AI shield regen. Like the Evolutions mod has it, so if you turn it on in the server admin mod, I believe they cancel each other out.

Problem 2, not entirely sure, but the first thing you should try is deleting EVERYTHING in your multiplayer saved game folder. I believe we had the same problem on the Freeworlds Evolutions server, and a complete player wipe fixed it.

Hope I helped, if not will have to wait for Chips to respond.


Post Sat May 22, 2004 1:12 pm

Thanks for your reply..
We had no other mods running and their are/were no files in the game folder. It is was a fresh install. Still have not figured it out. Sure would like to. Worked great for a while. Thanks again.

Post Sat May 22, 2004 1:17 pm

Ah - did you try to use the SDK instead - as the mod relies very heavily on scripting. At which point, the SDK is the one that will garuntee you have the same files as the mods been tested upon (see EOA Players consortium for SDK, or downloads of TLR).

For number 2 - do a FULL server wipe - erase ALL characters (none to be left at all!!) and that should (note the should ) fix the issue. Corrupt files, or running it without the mod at any point could have caused this - as save games with locked gates will corrupt ALL the saves with unlocked gates, and then more trouble occurs. Also - you might have to watch out for options with IFSO clashing with the mod. I never tested it with the Operator, mainly cause i didn't know anything about it at the time

Hope that fixes you up, as i am an ini junkie, and unfort not a server whizz!!

Post Thu Jul 01, 2004 12:42 pm

when u change the settings 2 a different ship it changes the game settings its like a mod at this point u need 2 go into mp player accounts and delete the accounts each time u change anything.
I used this mod several times testing as u did and had the same prob all i did was delete the accounts just as if I was actavating a new mod 4 1 of my servers
and it will work fine

Return to Pathfinder Studios