Important Message

You are browsing the archived Lancers Reactor forums. You cannot register or login.
The content may be outdated and links may not be functional.

To get the latest in Freelancer news, mods, modding and downloads, go to

help a newbie. dialog boxes are empty.

Here you can get help with applying those different MODifications for Freelancer

Post Fri May 20, 2005 3:33 pm

help a newbie. dialog boxes are empty.

I downloaded freelancer mod manager 1.3 and it works fine. I downloaded the monkeys 1.18 and monkey universe. The mod files unziped fine and the mod can be activated.

play the single player version.

The problem that I'm having is that the dialog boxes in the modified game are either empty or display "IDS?". This problem happens with all the menus (such as the the start up menu, save game menu, job postings in bars) and the converstaion dialog boxes (such as buying a reputation or listening to a rumor in a bar).

I installed SDK1.3, but the problem persists. OK, I'll admit that I have no clue what is causing the problem but I thought the update patch would fix it.

Any nonvulgar suggestion would be appreciated.

The monkey mods look like fun, but when the dialog boxes are empty I can't tell what game characters are telling me, or what faction I'm bribing to increase my reputation with.

Thanks in advance.

[email protected]


Post Sat May 21, 2005 11:48 am

sounds like a corrupted dll to me

Post Sat May 21, 2005 2:42 pm


I'm the creator of the two mods and your problem is a dll problem, as Cold_Void said.
This is however not a bug in the two mods, but just some "bug" on your PC.

To solve it, try this:

- Go to your FL directory and make it "non-writeprotected" (just rightclick on the folder where the original game is installed and go to properites. There should be an option to have it write protected. Uncheck this and apply it for all subfolders and files)

- I think you already have this, but just to be sure. You need the newest version of FLMM (1.3), the SDK 1.3 installed to your FL directory and the patched version of my mod

- If all this does not help, you can solve the problem manually. Activate the mod in FLMM. Then go to the folder "FLMM/mods/TheMonkeys1/Exe" copy all the files in there to your "Freelancer/Exe" Folder and the problem should no longer appear.

If it still does not work, please post it here and I will try to help you.

Thanks for playing the mods. It was quite a lot of work to create them and I'm always happy to see someone playing my mods. This is a good motivation to go on. I'm already working on the next version of The Monkeys.

So, have fun playing and stay tuned for version 1.2!

Black Eagle

Post Wed May 25, 2005 5:35 am

Thanks for the help Black Eagle.

I tried the file properties solution. I couldn't find anything marked "write protect". I'm running Win 98 SE. There was a property marked "read only", but that was not l\selected for any of the folders, sub-fulders, or files.

I tried the manuel solution by copying all the files over and that provided a limited fix. The default dialog boxes, such as: save, load, etc..., showed up. I still have an "IDS!" message for the custom dialogs, such as commodity tourist.

I dunnow what the deal is. I'm gonna keep trying as the monkey MODs look great and are fun. That and I like problems to solve.


Post Wed May 25, 2005 3:14 pm

i have a question about computers not freelancer i know this is a freelancer forum but i dont know any other ones

im upgrading my computer and would like to know if ican put 2 RAMs in 1 computer?

also if you know anyone with spare parts that i can add to a computer please reply i will pay up to $30 im 14 so dont have much money

please send replys to [email protected]

Post Thu May 26, 2005 5:04 am

Hi again!

Blackies, to be sure that all the names and infocards (also the new custom ones) show up, please do this.
As I explained in my last post, activate the mod in FLMM, then go to the exe folder of the mod (FLMM/mods/Monkeys1/exe) and copy all the fils in there to the Freelancer/Exe folder.

If you did this, make sure that the following files are in the "Freelancer/Exe" folder (this is the Exe folder in the FL game folder):


All these files should have been in the mod folder (FLMM/mods/Monkeys1/exe) and you should have copied them to the "Freelancer/Exe" folder.

Some more things:
- Are you using the latest version of FLMM?
- Do you see all the names and infos, if the mod is not activated and you play vanilla FL
- It would be good to have a clean install of FL, then install the FL SDK 1.3 (I'm not sure if the newest version 1.5 of the SDK works without problems, but you can also try this) and then activate my mod "The Monkeys 1.18 (Patched version)" or "Monkey Universe 1.84 Final"

If this does still not help, please reply and I will try to help you. But normally everything should be okay after this.

I hope it works and have fun playing!

EDIT: If you use the Monkey Universe Mod, make sure that you also copy the following two files to the Freelancer/Exe: battleground.dll and swshipinfo.dll!

Black Eagle

Edited by - Black Eagle on 5/26/2005 3:41:17 PM

Post Thu May 26, 2005 8:10 pm

Thanks again Black Eagle.

Unfortunetly the problem persists to some degree.

I did a complete uninstall and then a reinstall of Freelancer. Then I rebooted and installed SDK1.3. I using FLMM 1.31.

I dunno what the deal is. I don't have any problems with the dialog boxes in unmodified freelancer, nor in the monkey mods sice I copied the files over to the EXE directory like you suggested.

I can still play the monkey mods, just can't see what all the new rumors, commodities, or weapons are. It's a great MOD and I enjoy playing. More fun than a barrel o' monkeys. *chuckle*

I'm gonna take a break from trying to fix it for a few days.

P.S. I've been so impressed with all the MODs that I've seen, that I've decided to try my own hand at making a MOD. Hopefully I'll be posting something in the MOD announcement forum soon.


Post Fri May 27, 2005 1:16 pm

Hi again!

I'm very sorry that the problem is still there, but I don't know what causes this, as noone else has this bug and I also tested it again several times. It seems to be a problem specific to your PC.

One last thing: As you now reinstalled FL and the SDK, try to download the Patched version of my mod again (You should of course at first deactivate the old monkey mods and delete them from FLMM). Then activate it and do not copy anything. This would just be the normal way, but maybe your download was somehow mistaken and it works with a newly downloaded mod.

I hope it finally works.

It's great to hear that you want to start with modding. We really need new modders, who keep FL alive and try out new things.
When I started modding about one and a half year ago, I did not know anything about it and learned many many things from reading the forums and the tutorials.
So, I can only say that you have to read a lot, but it is really worth the time.

And of course, if you have any questions you cannot answer, feel free to ask them here in the forums. The good modders will surely help you and I will also do so, if I can.

So, good luck and have fun modding!!! Great!

One more thing, do you want to start an own project, or do you want to work with someone else on an existing project?

Black Eagle

Post Fri May 27, 2005 2:15 pm

I had a simular problem with wts 2.53 (i've been away for a little while) but still does it in 2.74, that i can ether see all the gun and equipment names or i could see all the system, ect. names. i managed to solve it back in 2,53 but i had to reinstall FL then i put the wts dll in the exe folder, then a few other things(can't remember).

But i did fix it after a hr of playing with it....

p.s my problem was caused by my dll that i was using for my mod (the empty dll)

Edited by - NightHound on 5/27/2005 3:16:34 PM

Post Sat May 28, 2005 9:05 am

Black Eagle

Thanks you for the reply.

Right now I'm working on my own pet project MODs. I'm learning the basics and what the commands are, such as filereplace and fileappend, and so forth.

I'm certainly not opposed to helping someone out with an existing project, but I'm not sure how much help I could be due to my very limited experience and know-how.

I just send a flmod file and hope to see it in the mod announcement forum for freelancer. The mod has to do with the nomad laser. I really like the nomad weapons.


Post Sat May 28, 2005 1:38 pm

Just to see if the mod gets activated properly,
get into your Freelancer/EXE folder and open "freelancer.ini"
Search for each of the dlls that contain names (Black Eagle could tell you which)
if they are all there and are all pointing to the right directory and are not commented (Having a ; at the beginning), then try to uninstall Freelancer, then Freelancer Mod Manager, then DELETE the Freelancer directory and reinstall everything.

hope this helps,

Return to Freelancer Using MODs Help Forum