Important Message

You are browsing the archived Lancers Reactor forums. You cannot register or login.
The content may be outdated and links may not be functional.

To get the latest in Freelancer news, mods, modding and downloads, go to

Mouse Delay

The place to ask for technical help with running the demo or the full game...

Post Mon Mar 27, 2006 3:11 am

Mouse Delay

When I play Freelancer, there is a small, but noticable delay in mouse movement. How do I eliminate this?

I'm running Freelancer on an Acer Laptop with a 1.8GHZ AMD Turion.
Is this a product of using the AMD processor? I didn't get this problem on my 700MHz Pentium.


Post Mon Mar 27, 2006 8:49 am

Turn up mouse sensitivity. If it's not in the options menu of the game (F1) or options from main menu), then take a peek in your windows install, control panel, mouse, pointer speed.

Of course, graphics lag can appear as slow mouse movement (or delayed), as well as memory issues (not positive on memory by the way - just guessing) - so what specs you running etc.

Post Mon Mar 27, 2006 9:58 am

I'm running on minimum detail.

The mouse delay I'm talking about is mostly during the periods when you get a pointer. (such as the entry screen, and on-planet screens)

I'm running it in a window with 1024x768 (Widescreen laptop, so can't run fullscreen without streching) resolution

Post Tue Mar 28, 2006 6:13 am

Had that too on a regular basis with my old Logitech MX 510 / 518. Make sure mouse acceleration is turned off in your mouse driver. Generally speaking, it is better to let windows handle the mouse's primary functions that the vendor's driver.

You might also consider to tweak your mouse a bit, if it's plugged in via USB. You then can raise the USB pollrate (standard = 120hz) up to insanely high levels (around 2000hz). However, it might happen that your other USB hardware doesn't like such high pollrates and start to malfunction. Trial & error on this one, I'm afraid.

Return to Freelancer Technical Issues