Important Message

You are browsing the archived Lancers Reactor forums. You cannot register or login.
The content may be outdated and links may not be functional.

To get the latest in Freelancer news, mods, modding and downloads, go to

My planet is invisible?!

The general place to discuss MOD''ing Freelancer!

Post Sun Jun 03, 2007 11:36 am

My planet is invisible?!

Hey, i'm new to modding so there may be a simple error that I'm not noticing but any help will be appreciated. I'm trying to make a moon, and I've got all the .mat and .txm files named and placed in my mod's solar\planets\planet_luna_800 folder. This is the code I added to the SolarArch.ini:

[Solar <---- end bracket doesn't show up
nickname = planet_luna_800
ids_name = 60205
ids_info = 60206
type = PLANET
DA_archetype = solar\planets\planet_luna_800\planet_luna_800.sph
material_library = solar\planets\planet_luna_800.txm
material_library = solar\planets\detailmaps\detailmap_city.txm
material_library = solar\planets\atmosphere.txm
material_library = solar\planets\planet_luna_800\planet_luna_800.mat
mass = 1000000
solar_radius = 800

All I did was rename some of the existing planet files for this moon. It worked with a larger planet I made. The .sph file was originally planet_crater_800.sph, as was the .txm file. The .mat file was planet_earthcity.mat.

Here's what I put in the system's .ini:

nickname = So01_02
ids_name = 196766
pos = 88504, 5000, 34022
rotate = 0, 0, 0
ambient_color = 10, 10, 10
Archetype = planet_luna_800
ids_info = 65759
spin = 0, 0.010000, 0
atmosphere_range = 900
burn_color = 125, 125, 125

If someone could elaborate as to what's wrong I'd really appreciate it. Else I may have this problem for the rest of my mod. Thanks

EDIT: I tried switching the object archetype to planet_crater_800 and that shows up fine, so it has to be something wrong with the solararch.ini code. Just figured it would make things easier.

Post Sun Jun 03, 2007 11:52 am

This happened to me.I added planet with solar radius 3000 and i added atmosphere range and damage zone size below 3000.After it i added a docking ring and when i undokced i was actually inside the planet.I flew away a bit when planet appeared.The docking ring was inside it.If you dont have a docking ring then i dont know whats wrong.

Post Sun Jun 03, 2007 1:30 pm

As a general rule if you can't see it and you haven't CTD'd then it's usually texture related.

In the SPH you have 7 nodes M0-M6, these hold the material assignments for the six faces and 1 atmosphere of each SPH, if those assignments don't match with the material's in the MAT then you get an invisible planet. The same happens if the texture assignments used in the "xx_name" nodes of the MAT can't find the textures in the TXM's.

As a small note, you don't always have to make a new SPH for a given situation, in the PLANETS folder about a third of the SPH's don't have a solararch.ini entry.

**shuffles off with a new headache**

Edited by - Bejaymac on 6/3/2007 2:31:00 PM

Post Sun Jun 03, 2007 3:15 pm

Thanks loads, that solved all my problems.

Post Mon Jun 04, 2007 8:11 am

Which solution fixed your problem?

Requiem: A Total FL Conversion Mod .

Post Tue Jun 05, 2007 3:16 am

This happened to me with custom planets out of cmps. Sometimes they are visible, sometimes not.

Return to Freelancer General Editing Forum